sinet.com.kh

Tuesday, December 11, 2018

Load Sharing 2 WAN and 1 LAN (Using Rules)

Today we will show you how to configure Load Sharing 2 WAN and 1 LAN (Using Rules) detail as bellow:
1. Comment Interfaces
2. Create Bridge LAN
3. Configure IP Address for WAN1
4. Configure IP Address for WAN2
5. Configure IP Address for Bridge LAN
6. Configure DNS Server
7. Configure DHCP Server
8. Configure Routes
9. Configure Rules
10. Configure NAT
11. Add Port to Bridge LAN

WAN1: 203.217.169.76/27
WAN2: 202.84.75.242/29
Bridge LAN:  10.12.15.252/22
LAN Gateway: 10.12.15.252
10.12.12.0/24 to SINET
10.12.13.0/24 to SINET
10.12.14.0/24 to SINET
10.12.15.0/24 to CityLink 

In this configuration we use MikroTik RB2011UiAS-2HnD with Firmware v6.42.2
1. Comment Interfaces
/interface ethernet
set [ find default-name=ether1 ] name=ether1-SINET
set [ find default-name=ether2 ] name=ether2-CityLink

2. Create Bridge LAN
/interface bridge
add fast-forward=no name=bridge-LAN

3. Configure IP Address for WAN1
/ip address
add address=202.84.75.242/29 interface=ether2-CityLink network=202.84.75.240

4. Configure IP Address for WAN2
/ip address
add address=203.217.169.76/27 interface=
ether1-SINET network=203.217.169.64

5. Configure IP Address for Bridge LAN
/ip address
add address=10.12.15.252/22 interface=bridge-LAN network=10.12.12.0

6. Configure DNS Server
/ip dns
set servers=8.8.8.8
,8.8.4.4

7. Configure DHCP Server
/ip dhcp-server network
add address=
10.12.12.0/22 dns-server=8.8.8.8,8.8.4.4 gateway=10.12.15.252

/ip pool
add name=dhcp_pool1 ranges=
10.12.12.1-10.12.12.251

/ip dhcp-server
add address-pool=dhcp_pool1 authoritative=after-2sec-delay disabled=no     interface=Bridge-LAN lease-time=1d name=dhcp1
 

8. Configure Routes
/ip route
add check-gateway=ping distance=1 gateway=203.217.169.65
add check-gateway=ping distance=1 gateway=202.84.75.241
add check-gateway=ping distance=1 gateway=203.217.169.65 routing-mark=TO_SINET
add check-gateway=ping distance=1 gateway=202.84.75.241 routing-mark=TO_CityLink
 
9. Configure Rules
/ip route rule
add dst-address=10.12.12.0/22 table=main
add dst-address=172.16.1.0/24 table=main
add src-address=10.12.15.252/32 table=main

add src-address=10.12.12.0/24 table=TO_SINET
add src-address=10.12.13.0/24 table=TO_SINET
add src-address=10.12.14.0/24 table=TO_SINET
add src-address=10.12.15.0/24 table=TO_CityLink

10. Configure NAT
/ip firewall nat
add action=masquerade chain=srcnat

11. Add Port to Bridge LAN
/interface bridge port
add bridge=bridge-LAN interface=ether3
add bridge=bridge-LAN interface=ether4
add bridge=bridge-LAN interface=ether5
add bridge=bridge-LAN interface=ether6
add bridge=bridge-LAN interface=ether7
add bridge=bridge-LAN interface=ether8
add bridge=bridge-LAN interface=ether9

No comments:

Post a Comment