sinet.com.kh

Thursday, March 22, 2018

Transparently Bridge two Network using MPLS

Station (1)
1. Comment Interface
2. Configure IP Address
3. Enable LDP
4. Configure VPLS Tunnel
5. Create Bridge and Add Ports to Bridge

Station (2)
1. Comment Interface 
2. Configure IP Address
3. Enable LDP
4. Configure VPLS Tunnel
5. Create Bridge and Add Ports to Bridge 

In this MPLS configuration we will change MTU size to 9000. For Station (1) we use MikroTik  CCR1036-8G-2S+ with Firmware 6.37.3 and Station (2) we use MikroTik CCR1036-12G-4S with Firmware 6.41.2

Station (1)
1. Comment Interface and Set MTU to 9000
/interface ethernet
set [ find default-name=ether1 ] l2mtu=9080 mtu=9000 name=ether1-to-Station-2
set [ find default-name=ether2 ] auto-negotiation=no l2mtu=9080 mtu=9000
    name=ether2-to-Customer 
2. Configure IP Address
/ip address
add address=172.16.0.1/30 interface=ether1-to-Station-2 network=172.16.0.0

3. Enable LDP and Set MPLS Interface to 9000 (MPLS MTU)
/mpls ldp
set enabled=yes lsr-id=172.16.0.1 transport-address=172.16.0.1
/mpls ldp interface
add interface=ether1-to-Station-2

/mpls interface
set [ find default=yes ] mpls-mtu=9000
4. Configure VPLS Tunnel
/interface vpls
add advertised-l2mtu=9000 disabled=no l2mtu=9000 mac-address=02:A7:17:CD:FD:C2 mtu=9000 name=vpls1 remote-peer=172.16.0.2 vpls-id=1:1

5. Create Bridge and Add Ports to Bridge
/interface bridge
add name=bridge1

/interface bridge port
add bridge=bridge1 interface=ether2-to-Customer
add bridge=bridge1 interface=vpls1



Station (2)
1. Comment Interface and Set MTU to 9000
/interface ethernet
set [ find default-name=ether1 ] l2mtu=9080 mtu=9000 name=ether1-to-Station-1
set [ find default-name=ether2 ] auto-negotiation=no l2mtu=9080 mtu=9000
    name=ether2-to-Customer


2. Configure IP Address
/ip address
add address=172.16.0.2/30 interface=ether1-to-Station-1 network=172.16.0.0

3. Enable LDP and Set MPLS Interface to 9000 (MPLS MTU)
/mpls ldp
set enabled=yes lsr-id=172.16.0.2 transport-address=172.16.0.2
/mpls ldp interface
add interface=ether1-to-Station-1

/mpls interface
set [ find default=yes ] mpls-mtu=9000


4. Configure VPLS Tunnel
/interface vpls
add advertised-l2mtu=9000 disabled=no l2mtu=9000 mac-address=d4:A7:17:CD:FD:77 mtu=9000 name=vpls1 remote-peer=172.16.0.1 vpls-id=1:1


5. Create Bridge and Add Ports to Bridge 
/interface bridge
add name=bridge1

/interface bridge port
add bridge=bridge1 interface=ether2-to-Customer
add bridge=bridge1 interface=vpls1


No comments:

Post a Comment